‏إظهار الرسائل ذات التسميات Proxy. إظهار كافة الرسائل
‏إظهار الرسائل ذات التسميات Proxy. إظهار كافة الرسائل

الأربعاء، 4 مارس 2015

Nuke-IOS An Auditing Tool To Test ARP Attacks For iOS


Nuke-IOS An Auditing Tool To Test ARP Attacks For iOS.

Its an auditing tool to test ARP attacks, can easily be avoided using Static-ARP entries on hosts or with AP isolation. Nuke-IOS (beta) Automated ARP poisoning script for IOS.

What Is ARP Poisoning?
ARP Poisoning attack is a type of attack. Generally, the aim is to associate the attacker's MAC address with the IP address of another host, such as the default gateway, causing any traffic meant for that IP address to be sent to the attacker instead.

ARP spoofing may allow an attacker to intercept data frames on a network, modify the traffic, or stop all traffic. Often the attack is used as an opening for other attacks, such as denial of service, man in the middle, or session hijacking attacks.

The attack can only be used on networks that use the Address Resolution Protocol.  Soon its support for SBsettings toggle, yes, one simple button that takes down an entire /24 network in seconds.

Depends on:
mptcp network-cmds

Download

الثلاثاء، 27 يناير 2015

Get Original IP Address Of Any User From STUN IP Address Requests For WebRTC

Get Original IP Address Of Any User From STUN IP Address Requests For WebRTC

Firefox and Chrome have implemented WebRTC that allow requests to STUN servers be made that will return the local and public IP addresses for the user. These request results are available to javascript, so you can now obtain a users local and public IP addresses in javascript. This demo is an example implementation of that.

What is STUN Server?
A STUN (Session  Traversal of User Datagram Protocol [UDP] Through Network Address Translators [NATs]) server allows NAT clients (i.e. IP Phones behind a firewall) to setup phone calls to a VoIP provider hosted outside of the local network.

The STUN server allows clients to find out their public address, the type of NAT they are behind and the internet side port associated by the NAT with a particular local port. The STUN protocol is defined in RFC 3489.

The STUN protocol allows applications operating behind a network address translator (NAT) to discover the presence of the network address translator and to obtain the mapped (public) IP address (NAT address) and port number that the NAT has allocated for the application's User Datagram Protocol (UDP) connections to remote hosts. The protocol requires assistance from a third-party network server (STUN server) located on the opposing (public) side of the NAT, usually the public Internet.

Additionally, these STUN requests are made outside of the normal XMLHttpRequest procedure, so they are not visible in the developer console or able to be blocked by plugins such as AdBlockPlus or Ghostery. This makes these types of requests available for online tracking if an advertiser sets up a STUN server with a wildcard domain.

Code
Here is the annotated demo function that makes the STUN request. You can copy and paste this into the Firefox or Chrome developer console to run the test.

Get the IP addresses associated with an account

function getIPs(callback){
    var ip_dups = {};

    //compatibility for firefox and chrome
    var RTCPeerConnection = window.RTCPeerConnection
        || window.mozRTCPeerConnection
        || window.webkitRTCPeerConnection;
    var mediaConstraints = {
        optional: [{RtpDataChannels: true}]
    };

    //firefox already has a default stun server in about:config
    //    media.peerconnection.default_iceservers =
    //    [{"url": "stun:stun.services.mozilla.com"}]
    var servers = undefined;

    //add same stun server for chrome
    if(window.webkitRTCPeerConnection)
        servers = {iceServers: [{urls: "stun:stun.services.mozilla.com"}]};

    //construct a new RTCPeerConnection
    var pc = new RTCPeerConnection(servers, mediaConstraints);

    //listen for candidate events
    pc.onicecandidate = function(ice){

        //skip non-candidate events
        if(ice.candidate){

            //match just the IP address
            var ip_regex = /([0-9]{1,3}(\.[0-9]{1,3}){3})/
            var ip_addr = ip_regex.exec(ice.candidate.candidate)[1];

            //remove duplicates
            if(ip_dups[ip_addr] === undefined)
                callback(ip_addr);

            ip_dups[ip_addr] = true;
        }
    };

    //create a bogus data channel
    pc.createDataChannel("");

    //create an offer sdp
    pc.createOffer(function(result){

        //trigger the stun server request
        pc.setLocalDescription(result, function(){});

    }, function(){});
}

//Test: Print the IP addresses into the console
getIPs(function(ip){console.log(ip);});

Download

الجمعة، 20 يونيو 2014

How To Configure Tor and Privoxy Using Proxy Chains In Kali Linux


How To Configure Tor and Privoxy Using Proxy Chains In Kali Linux as Anonymous way ?
Follows to use tor as a proxy in order to use the tools of Kali (1.0.7).

Objective: To study purposes.

#Adding Repository


#Installing the key

gpg --keyserver keys.gnupg.net --recv 886DDD89
gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

#Update the repositories
#Installing Tor and Privoxy

#Edit the file:
#Edit the lines 776 and 1292, as follows:

listen-address 127.0.0.1:8118
forward-socks5 / 127.0.0.1:9050.

#Restart the services
#Edit the file:
#Comment (#) line 38 and 64, as follows:

#proxy_dns 
#socks4 127.0.0.1 9050

#And insert the end of the file:
socks5 127.0.0.1 9050

Using
In the browser (Iceweasel), go to Preferences >> Network >> Settings >> Setar Manual proxy: 127.0.0.1:8118, and to enable all protocols. 
#To test the navigation, go to: https://check.torproject.org/?lang=pt_BR 
#To use the tools, always use the proxychains forward commands. 
example:

proxychains nmap -sV <www.localhost.com>

proxychains nikto -host <www.localhost.com>

proxychains msfconsole

Source: CHMOD0DAY

الأربعاء، 18 يونيو 2014

Ghost Phisher Python Tool For Wireless And Ethernet Security Testing


Ghost Phisher is a Wireless and Ethernet security testing tool written in Python Programming Language and the Python Qt GUI library.The program is able to emulate access points , conduct Phishing and Penetration Testing Attacks including the creation of a fare AP Network for Testing Purposes.

The particularity of this Tool is that includes an entire Section for Credentials Fetching and allows the Creation of a Fake DNS Server, Access Point, HTTP and DHCP Server.

Credential Fetching Method:




Operating System Supported:

>> Ubuntu KDE/GNOME

>> BackTrack Linux

>> BackBox Linux

>> Prerequisites

The Program requires thus packages:

>> Aircrack-NG

>> Python-Scapy

>> Python Qt4

>> Python

>> Subversion

>> Xterm

>> Metasploit Framework (Optional)


You can install it using following Command:
"apt-get install program"

In Debian, you can use following Command:
root@host:~# dpkg -i ghost-phisher_1.5_all.deb

Do you need to Update the Program: 
Don't worry, While there's a new Update, it will appear directly when the program is running!.

Features:

>> HTTP Server
>> Inbuilt RFC 1035 DNS Server
>> Inbuilt RFC 2131 DHCP Server
>> Webpage Hosting and Credential Logger (Phishing)
>> Wifi Access point Emulator
>> Session Hijacking (Passive and Ethernet Modes)
>> ARP Cache Poisoning (MITM and DOS Attacks)       -----------> 



>> Penetration using Metasploit Bindings
>> Automatic credential logging using SQlite Database
>> Update Support

Download Link:
New version 1.52 is available
https://code.google.com/p/ghost-phisher/downloads/list


Project Source Code:
root@host:~# svn checkout 

http://ghost-phisher.googlecode.com/svn/Ghost-Phisher

About the Author :
Christian Galeone is a Cyber Security Researcher & Cyber Intelligence Analyst from Italy, he's studying to ITCL Marco Polo attending the I.T Class. During his Accreditation Process, he has been Accredited by lot of Big Companies such like Yahoo!, Microsoft, AT&T, Sony etc. His future goal is to be a Cyber Security Specialist working for the National Security in his Country.

الثلاثاء، 20 مايو 2014

How To Install Tor - Polipo Proxy With SQLMap [#Video]


How to install Tor - Polipo Proxy With SQLMap? 

Commands:


Install tor + polipo and then back up

# apt-get install tor tor-geoipdb polipo
# cp /etc/polipo/config /etc/polipo/config.bkp

Replace the config file polipo by the pastebin file

# vim /etc/polipo/config
ou
# gedit /etc/polipo/config

Polipo configuration file: 

http://pastebin.com/sRLvt0ue

Restart the services

# service tor restart
# service polipo restart

# python sqlmap.py -u "SITE HERE" --random-agent -v 3 --tor --check-tor --dbs --threads=5


Video: